Our Valued Sponsor
OpinionsConsumer ReviewsGuides and How TosCoffeeGeek ReviewsResourcesForums
Espresso: Espresso Mods and Restorations
Expobar Brewtus Steam Boiler overpressure.
Stefano's Espresso Care
Repair - Parts - Sales
Factory Authorized &
Trained Technician
www.espressocare.com
 
Not Logged in: Log In to Postlog in
New Topics updated topics   New Posts new posts   Unanswered Posts new unanswered  
Search Discussion Board search   Discussion Board FAQ faq   Signup sign up  
Discussions > Espresso > Espresso Mods > Expobar Brewtus...  
view previous topic | view next topic | view all topics
Author Messages
rayban
Senior Member
rayban
Joined: 30 Jun 2010
Posts: 2
Location: Alberta, Canada
Expertise: I like coffee

Posted Thu Dec 8, 2011, 11:27pm
Subject: Expobar Brewtus Steam Boiler overpressure.
 

hello,

looking for some direction on my Expobar problem.

Machine is a brewtus III-R with direct feed.
started to leak out from the steam pressure relief valve. presssure climbs until it pins the steam gauge and relief valve opens.
tested the pressure stat and seems to be fine.
any suggestions for troubleshooting steps, flow chart? have the schematics from expobar. hope to have some direction as to what sequence ECM.
would like to know this thing inside and out, plan on keeping it for life.
any suggestions?

Regards,

Mike
back to top
 View Profile Link to this post
benstineman
Senior Member


Joined: 17 Mar 2008
Posts: 2
Location: Midwest, US
Expertise: I love coffee

Espresso: Expobar Brewtus IV-R (2011)
Grinder: Baratza Vario 885
Vac Pot: Aeropress
Posted Fri Feb 24, 2012, 6:22pm
Subject: Re: Expobar Brewtus Steam Boiler overpressure.
 

Hello Rayban,

I am not trying to hijack your thread here, but I wanted to maybe give it a bump as I seem to be having the same issue with my IV-R which I just got in Dec2011.

Here are some video of mine doing what appears to be the exact same thing you described.

http://www.youtube.com/watch?v=lXhdcGGzBps

I am talking to Whole Latte Love about this via email - they suggested I let it cool down all the way to room temp to see if the pstat will "unstick" itself. I did that, but it does not seem to have changed. Here is the same behavior after cool down.

http://www.youtube.com/watch?v=lNaFFapIMkY

NOTE: My PID is configured for Celsius, not Fahrenheit.

Have you contacted your retailer or service provider as to what to do next? I will post updates on what I find out from WLL.

B
back to top
 View Profile Link to this post
benstineman
Senior Member


Joined: 17 Mar 2008
Posts: 2
Location: Midwest, US
Expertise: I love coffee

Espresso: Expobar Brewtus IV-R (2011)
Grinder: Baratza Vario 885
Vac Pot: Aeropress
Posted Sat Feb 25, 2012, 2:40pm
Subject: Re: Expobar Brewtus Steam Boiler overpressure.
 

After further tinkering, I am no longer convinced the pstat is at fault in my situation. The steam heating element is cycling normally, which to me would suggest the pstat is working as expected. However, the pump seems to be short cycling, as if the water level sensor in the boiler tank is malfunctioning. This in turn overfills the steam boiler and with the steam and water wand valves closed, it causes the OPV to open. Notice in my videos that the OPV pops every time the pump motor runs.

Still curious about your issue, Rayban. Does your pump run when your OPV opens or is it just pressure created by the heat?

Ben
back to top
 View Profile Link to this post
mpatl
Senior Member


Joined: 26 Mar 2013
Posts: 2
Location: Vancouver
Expertise: I love coffee

Posted Tue Mar 26, 2013, 9:06pm
Subject: Re: Expobar Brewtus Steam Boiler overpressure.
 

Something very similar started happening to me today.  I was watching television and heard a pop in the kitchen and thought it was a bird hitting the window.  Since it stopped I didnít know what it was until it did it again and I noticed the steam hissing.

This machine is about 15 months old.

I shut off the machine and vented the pressure down and then turned it on again.  The steam pressure builds way past 1.5 bar and at 2 when it is still rising, the over pressure valve pops.

Any ideas what has gone wrong?  I am waiting for the machine to cool down before I open it for investigation.  My first thoughts are that the pressure sensor is shot, or the heating element relay is shot.

Later... above was email to wholelattelove.      After opening it up I couldn't see anything out of the ordinary except all the zip ties were cracking off from the heat.  I replaced those but didn't see much else.  When I got the machine the ground wasn't connected to the sensor so the steam boiler overfilled and pushed water out the overpressure valve.  I had to go in and re-attach the ground.  I didn't see anything like that today and there was no evidence of it over filling, just over boiling.

Anyone have any suggestions??  Will report back when it is fixed.
back to top
 View Profile Link to this post
rayban
Senior Member
rayban
Joined: 30 Jun 2010
Posts: 2
Location: Alberta, Canada
Expertise: I like coffee

Posted Tue Mar 26, 2013, 10:42pm
Subject: Re: Expobar Brewtus Steam Boiler overpressure.
 

My problem turned out to be twofold, the solenoid fill valve was corroded and stuck. And the pressure regulating valve also failed ( not part of the Brewtus). I have a watts PRV. As it and the pressure gauge are installed in the basement with the softener, I installed a pressure valve beside the machine. So if the pressure is wrong I can see it at the machine.

Since then I have to clean the PRV often. I have well water so is very hard.

Hope you sort it out.
I was able to get a PDF file parts and expanded view of the Brewtus from zCafe.
If I can find it ill attach it, if not your supplier retailer should be able to get you one, sure helps for parts ordering/troubleshooting.

Regards,

rayban
back to top
 View Profile Link to this post
mpatl
Senior Member


Joined: 26 Mar 2013
Posts: 2
Location: Vancouver
Expertise: I love coffee

Posted Wed Mar 27, 2013, 8:54pm
Subject: Re: Expobar Brewtus Steam Boiler overpressure.
 

Thanks for letting me know what your problem was.  Thankfully my problem is now fixed.

Pressurestat was faulty.  I bought a new one from Espressotec in Richmond today and all is well again.  No reply from Wholelattelove.


edit.  wll replied 2 days after email implicating the p-stat (not too shabby for customer support)
back to top
 View Profile Link to this post
view previous topic | view next topic | view all topics
Discussions > Espresso > Espresso Mods > Expobar Brewtus...  
New Topics updated topics   New Posts new posts   Unanswered Posts new unanswered     Search Discussion Board search   Discussion Board FAQ faq   Signup sign up  
Not Logged in: Log In to Postlog in
Discussions Quick Jump:
Symbols: New Posts= New Posts since your last visit      No New Posts= No New Posts since last visit     Go to most recent post= Newest post
Forum Rules:
No profanity, illegal acts or personal attacks will be tolerated in these discussion boards.
No commercial posting of any nature will be tolerated; only private sales by private individuals, in the "Buy and Sell" forum.
No SEO style postings will be tolerated. SEO related posts will result in immediate ban from CoffeeGeek.
No cross posting allowed - do not post your topic to more than one forum, nor repost a topic to the same forum.
Who Can Read The Forum? Anyone can read posts in these discussion boards.
Who Can Post New Topics? Any registered CoffeeGeek member can post new topics.
Who Can Post Replies? Any registered CoffeeGeek member can post replies.
Can Photos be posted? Anyone can post photos in their new topics or replies.
Who can change or delete posts? Any CoffeeGeek member can edit their own posts. Only moderators can delete posts.
Probationary Period: If you are a new signup for CoffeeGeek, you cannot promote, endorse, criticise or otherwise post an unsolicited endorsement for any company, product or service in your first five postings.
Learn @seattlecoffeegear
Learn all about coffee, watch videos, read how-to articles.
www.seattlecoffeegear.com
Home | Opinions | Consumer Reviews | Guides & How Tos | CoffeeGeek Reviews | Resources | Forums | Contact Us
CoffeeGeek.com, CoffeeGeek, and Coffee Geek, along with all associated content & images are copyright ©2000-2014 by Mark Prince, all rights reserved, unless otherwise indicated. Content, code, and images may not be reused without permission. Usage of this website signifies agreement with our Terms and Conditions. (0.202826023102)
Privacy Policy | Copyright Info | Terms and Conditions | CoffeeGeek Advertisers | RSS | Find us on Google+